HP Support: FAIL

Hey I’m back on planet gnome isn’t it cool? Many thanks to Lucas and Jeff!

Some of you may already know that I’ve been laptop less in the past three months. Since about mid September display started to behave odd: it randomly turns off the lamps until I close and reopen the lid, then after about half a minute it turns off again, then again on, and so on. Sometimes it even starts blinking like a crazy stroboscope :D .
Long story short, here is a little video of the crazy display. Awesome, isn’it?

Unfortunately this little issue is a bit difficult to reproduce, sometimes it does it the whole day, and believe me, it’s quite irritating, sometimes it doesn’t for several days… Sometimes it does it only early in the morning (cold lamps?).

I contacted HP Support and they argued it could be a motherboard issue.
A motherboard issue, at least in Italy is under a 2-year pick-up-and-return warranty.
So they sent it to their repair center (actually an external one: A-NOVO Italia, Saronno) and sent it back after about two of weeks with a nice HP headed sheet stating they didn’t find any issue at all and just restored the operative system (a laptop coming with a motherboard issue and they did just that?). They also installed and ran a couple of benchmarks and other test software that said everything was ok, and I guess nothing more.

Guess what… display started blinking again 2 days after.
I contacted again HP, already a bit upset, I talked with another technician and he said his colleague was surely wrong. I had no motherboard issue but just some lamp or hinge one. It was covered by one year warranty with the producer and one with the seller.

Ok, I then went to the seller and told them about the previous story.
They sent the laptop to the very same repair center with a long description saying that it was a bit an unpredictable issue, that it was just been there some week before and suggesting to test it carefully this time. It was the December 1st.

Three days ago I was called to take back the laptop. Same HP headed sheet, all tests were successful, no issue found. Oh, they did a BIOS update, damn you receive a laptop for repair twice with the very same issue and you just run some test and do a BIOS update? Seriously, a BIOS update?!

Needless to say screen started blinking again soon. You can see it in that video taken a couple of hours ago and I can see it in front of me right now.

I don’t know if I feel more upset or frustrated… still I cannot believe how a repair center can suck this way… they didn’t even try to replace the lamps! they didn’t even unmount the display to check the cables!

2 comments ↓

#1 Albert on 01.12.09 at 3:54 pm

I had the same kind of experience with them. My problem was that the laptop was losing the connection with the hardrive, the system seemed to work for a time because of the ram but when I was rebooting the BIOS was telling me that no hard drive was installed. The first time I send the latptop to HP they saw Grub and linux so they format the laptop and re-install Windows… and so you can imagine that I lost my data but my backup… The second time I remove myself linux and I put in background the image of the bios with the “no hard drive detected” same things. After a year to fight with them they proposed me to re-imburse me but with the value of my pc decrease by the time I was “using it” so basically I was losing 2/3 of my money. By chance I was living in US and so I contact the better business bureau (BBB) an organisation to help you for this kind of problem and they did a good job. I have been reimburse 80% (not perfect but better than 30%…) and I will NEVER buy another HP laptop, never. They are just incompetent.

#2 Shawn on 01.13.09 at 12:21 am

I hate that.. I’ve had no problem with my HP laptop.. but I did have customer service issues with my mega expensive Alienware. Purchased because it was supposed to be higher quality and extraordinarily fast! And it was, for about 6 months. I figured Eh, no biggie, that’s why I bought the extended ***ON-SITE*** warranty..

Needless to say, 1 year later.. YES 1 YEAR, i finally threw the POS away. They claimed their on-site warranty didn’t cover diagnosis and they couldn’t narrow down the over heating to the CPU or the GPU.. so, for the year, they ran me through red tape, unbelievable frustration, until the point I had had enough and finally purchased an HP for a 10th the cost. It has worked longer and more reliably then my Alienware ever did!

A year after that, they sent me a special offer for their -valued- customers.. I wrote back and told them they had some nerve after the BS the put me through and repeated the entire story..

Needless to say, I still wasn’t valued.. they responded, not even with an apology, let alone anything for my troubles, but instead an explanation that the email was automated without any research..

to anyone thinking of alienware.. RUN AWAY! I decided I’d buy cheap from now on, with the understanding that I’d probably just end up replacing it annually.. if I’d stuck with that plan, I’d have bought 2-3 laptops since then and still wouldn’t have paid as much as I did for the one Alienware. Fortunately, I haven’t had to buy another.. I runs gnome/linux swimingly!

I should take alberts advice and talk to the BBB. I threatened alienware with that, but was so frustrated by that point, I never followed through.. probably too late now. (I litterally threw it away)