Enough is enough

11:41 pm gnome, ubuntu

I waited several month for Ubuntu 11.04 to stabilize on my good old Power G5. No way in hell. Even X does not start properly. Had to spend several months in MacOS :(( So… considering that I have no interest whatsoever in Unity and other heavily patched gnome components of Ubuntu …  It is Debian now, testing + gnome 3 from experimental. Well, gnome 3 starts in fallback mode only so far – but at least that’s better than absolutely non-working X.

On my laptop, virtualbox for some reason went to disagreement with Ubuntu (inside) as well, so now I have FC15 inside VB, with nearly vanilla gnome3 (working properly with gnome-shell!).

I was some kind of fan of Ubuntu. I am leaving that camp for now. Political reasons, personal reasons, technical reasons… Perhaps, for me 10.10 was the finest hour of Canonical. So long.

14 Responses

  1. Raphael Says:

    Hey, basically the same thing here … then I realized I had only switched to Ubuntu back in the 4.10 days because it had the latest Gnome release all ready for you – now I’m on Arch Linux, which was quite the revelation. I’m just hoping Ubuntu will stabilise and be usable again – would be a shame to see a project like this go down because of politics or anything like that…

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  2. Andrew Says:

    Funnily I switched from Ubuntu to Debian Unstable a few months ago because Ubuntu wasn’t very stable for me and Debian Unstable was almost rock solid (only a few glitches which were fixable).

    I haven’t looked back since.

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  3. lachlan Says:

    I left Ubuntu during 6.10 for Debian testing.

    It has never worked as well as a “just works” distro should have.

    Ubuntu bashing aside your G% would be PPC right? Ubuntu did drop official PPC support so Debian is probably a much better choice for you anyway.

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  4. Simon Says:

    I still quite like Ubuntu on my netbook, since I find Unity works better on the small screen than either Gnome 2 or 3, and that’s more important than pretty much any other aspect of a distro.

    But yeah, gone back to Fedora for my regular desktop… not 100% happy with that (I need to look at Gnome3 shell extensions to fix some of the annoying quirks), but happier than with Ubuntu on that machine…

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  5. Alan kmowles Says:

    In getting there, 11.04, with gnome3 ppa, only just works. But its really unstable. Unity hacks have messed up quite a few packages. Suspend/resume fails one in ten times.

    What’s worse is i upgraded my wifes netbook from 10.04 to 11.04, she finds the new unity look confusing and buggy, and i get the blame for that;)

    My office debian, while not as sexy as shell, is at least rock solid with compiz.

    Lets hope shell gets fixed on debian

    Feeling your pain….

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  6. Sergey Udaltsov Says:

    @lachlan: yes it is ppc, yes it was not official – but 10.10 was good enough on that platform

  7. Lumag Says:

    I’ve checked Ubuntu several times. While being usefull as a LiveCD / giveaway Linux, while having some good things like PPA, for me it was always a bit unstable. And PPA repos usually can be used on Debian.

    P.S. Debian testing. On x86, PPC and ARM. Switched from gnome to xfce after 3.0, so I cannot comment on 3.0 status in Debian.

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  8. T_U Says:

    I still like Ubuntu for many reasons, but it’s true Natty was the last straw to many of us. It had *many* issues (which are not completely fixed yet) + Unity which is not ready for primetime.

    Well, that’s sad considering the great amount of work the community & Canonical did.

    I hope they’ll learn from their mistakes. As for as I’m concerned, I recommend LTS versions to people now.

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  9. Matteo Settenvini Says:

    PowerPC iMac G5 here, switched from Ubuntu to Debian unstable some weeks ago, for exactly the same reasons. I am even using the experimental repo for getting GNOME 3.

    Some small issues with Iceweasel (endianness issues with the JS engine, I guess, since Iceweasel crashes on sites like GMail), but Epiphany works reliably.

    Unfortunately, the nouveau driver for PowerPC is the slowest thing in the galaxy. Working on at the PPC seems like using a PIII 300 MHz… and looking at a HTML5 video element is plain impossible.

    I hope someone enables the full 3D stack also on these machines; they are still fine, and GNU/Linux is the only up-to-date full-fledged system you can run on them without much hassle.

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  10. Steve Says:

    I had been with Ubuntu since Dapper Drake. Stability was never a strong point (I used Slackware before Ubuntu), but Ubuntu was an easy distribution to use. But one look at Natty made me decide that it was time to install Debian stable… because it’s stable.

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  11. quindo Says:

    Currently gnome-shell doesn’t work in debian experimental because it uses libmozjs4d. That has been pulled from debian (security issues i think). If you have gnome-shell installed then install libmozjs5d and ln -s /usr/lib/libmozjs.5d.so libmozjs.4d.so and gnome-shell should work again :-)

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  12. Sergey Udaltsov Says:

    @quindo: My impression is that today they fixed that dependency.

  13. peter Says:

    Same as the first commenter: I switched to arch 4 weeks ago. I didn’t even try 11.04, mostly technical reasons. 10.10 was the last version.

    Thank you Canonical, you made me move to linux.

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.

  14. Onkar Says:

    Thanks for the warning. I was planning to upgrade to 11.04 on my ibook G4. Looks like I will wait till 11.10 comes out and do a reinstall.
    By the way, my second OS on same machine is Debian testing. Is the gnome3 good enough to justify an upgrade to Debian unstable?

    [WORDPRESS HASHCASH] The poster sent us ‘0 which is not a hashcash value.