Finally 0.5.4 with rotation

January 15, 2008

Hi,

After holidays and slow work, if finaly release 0.5.4 including processing infrastruture and rotation. There is other enhancement and bug fixes detailed in the NEWS file. This release is in sync with GEGL r1840. GEGL might provide a 0.0.16 release for march, i wish Gnome Scan 0.6 will arrive sync in march.

Thanks to Gnome wonderful admins, i now have access to Gnome FTP. install-module is a pretty handy tool ! So now, the download site is http://ftp.gnome.org/pub/GNOME/sources/gnome-scan/. You’ll find tarballs in http://ftp.gnome.org/pub/GNOME/sources/gnome-scan/0.5/. Packages are already uploaded to my PPA.

Please report test it and report bugs. I know this release has some bugs and i wish to get it stable for march. I want to add PDF output and that should be ok for 0.6. The rest will be bug fixes. I prefer to reject features for 0.8 (more processing, etc.). I might update AbiScan for use with 0.6 and latest ocropus, but nothing sure.

Étienne

3 Responses to “Finally 0.5.4 with rotation”

  1. Antonis Kaladis Says:

    Well done. I never understood why Ubuntu never shipped with this installed. It’s much saner (pun intended) than that XSane.

    I have been using gnome-scan for a while now. When I upgraded to the PPA packages, I first thought that my scanner was no longer being detected properly. When I finally let gnome-scan run for a while, it showed up (it takes a few seconds for it to show up). Old versions used to show a ‘splash’ with a ‘probing’ message. Now it’s not really apparent what’s going on. Some visual clue would be great.

    Other than that, I can’t really complain about anything. OCR-related stuff and tighter integration with other applications is brownie points as far as I’m concerned.

    Keep it up :)

  2. Sorbus Says:

    Bonjour Etienne,

    Quelques recherches sur la ROC sous Linux m’ont conduit à tes billets sur Tesseract… puis à gnome-scan et au plugin pour Abiword.

    J’avais installé la version 0.4 de Gnome scan par Synaptic… Je l’ai désinstallée dans le but d’installer la 0.5.4. Mais je n’y arrive pas. Je suis sous Ubuntu Gutsy. D’abord, après avoir lancé ./configure, j’avais “configure: error: SANE not found” en fin de terminal. Ce qui m’a conduit ici : http://gnome-scan.blogspot.com/2006/08/gnomescan-01-road-to-maturity.html
    (cf. le commentaire en bas de page).
    J’ai donc installé libsane-dev et recommencé ./configure.
    … ça va mieux… mais j’ai encore ça en fin de terminal :

    checking for GNOME_SCAN… configure: error: Package requirements (gmodule-2.0 gthread-2.0 glib-2.0 gdk-2.0 >= 2.11 gdk-pixbuf-2.0 gtk+-2.0 gegl >= 0.0.15) were not met:

    No package ‘gmodule-2.0′ found
    No package ‘gthread-2.0′ found
    No package ‘glib-2.0′ found
    No package ‘gdk-2.0′ found
    No package ‘gdk-pixbuf-2.0′ found
    No package ‘gtk+-2.0′ found
    No package ‘gegl’ found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GNOME_SCAN_CFLAGS
    and GNOME_SCAN_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.”

    Je ne peux donc pas passer à l’étape “make”.

    Je n’ai pas regardé pour les autres paquets, mais “gmodule-2.0″ n’est pas disponible dans les dépôts.

    Voilà tout… Je dois manquer une étape.

    Merci et bon Carême ;-)

  3. Étienne Bersac Says:

    Salut Sorbus,

    AbiScan est uniquement une preuve de principe, rien de vraiment utilisable, faute de contributeurs :/

    Pour la compilation de la 0.5.4, sache qu’il y a des paquets à jours dispo sur ma PPA : http://launchpad.net/~bersace/+archive . Pour gutsy.

    Enfin, ce genre de message n’a rien à faire sur un commentaire, mieux vaut me contacter directement ou via le bugzilla …

    Bon Carême également.


Comments are closed.