Shotwell 0.15 has arrived

We at Yorba are pleased to bring you Shotwell 0.15. This version has several enhancements:

  • Copy and paste color adjustments between photos
  • Highlights detail adjustment
  • YouTube plugin now uses OAuth / OpenID
  • Videos in Missing Files now re-import properly
  • Improvements when thumbnailing videos
  • Numerous bug fixes

The Shotwell 0.15 tarball is available for download. See the installation guide for information on getting Shotwell on your system. Report bugs and feature requests at Yorba’s Redmine server. (You must create an account before adding or modifying tickets there.)

Ubuntu users can also find a version for Raring Ringtail (13.04) and Quantal Quetzal (12.10) on Yorba’s PPA. Adventurous users may also wish to subscribe to Yorba’s Daily PPA.

14 thoughts on “Shotwell 0.15 has arrived”

  1. This update seems to break the packages:

    Resolving dependencies…
    The following NEW packages will be installed:
    libgexiv2-2{a}
    The following partially installed packages will be configured:
    shotwell
    0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B/46.0 kB of archives. After unpacking 148 kB will be used.
    Do you want to continue? [Y/n/?]
    (Reading database … 515124 files and directories currently installed.)
    Unpacking libgexiv2-2 (from …/libgexiv2-2_0.6.1-0ubuntu1_i386.deb) …
    dpkg: error processing /var/cache/apt/archives/libgexiv2-2_0.6.1-0ubuntu1_i386.deb (–unpack):
    trying to overwrite ‘/usr/lib/libgexiv2.so.2.0.0’, which is also in package libgexiv2-1 0.7.0-0raring1
    No apport report written because MaxReports is reached already
    Errors were encountered while processing:
    /var/cache/apt/archives/libgexiv2-2_0.6.1-0ubuntu1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    dpkg: dependency problems prevent configuration of shotwell:
    shotwell depends on libgexiv2-2 (>= 0.4.1); however:
    Package libgexiv2-2 is not installed.

    dpkg: error processing shotwell (–configure):
    dependency problems – leaving unconfigured
    Errors were encountered while processing:
    shotwell

  2. Hi There!

    Thanks for Shotwell 0.15! I can hardly wait to check its new features.
    Unfortunately, my Quantal installation does not meet its dependencies.

    ‘sudo apt-get install shotwell’ says:
    > The following packages have unmet dependencies:
    > shotwell : Depends: libgee-0.8-2 (>= 0.8.3) but it is not going to be installed
    > E: Unable to correct problems, you have held broken packages.

    Any ideas where to get a current libgee from?

    Cheers, Stefan

  3. After upgrading from .12 on Ubuntu 12.04 (precise) it threw this error on launch:

    shotwell: error while loading shared libraries: libgexiv2.so.2: cannot open shared object file: No such file or directory

    Looks like bug 5965 addressed this issue in shotwell .13 and the fix was:

    sudo apt-get install libgexiv2-1

    which did fix the problem.

  4. Hello, folks.
    Thanks for developing Shotwell! If I understood correctly, Shotwell 0.15 support for Ubuntu Precise was not planned due to the obsolescence of the libs, above all libgee, for this Ubuntu release (cfr. http://permalink.gmane.org/gmane.comp.gnome.apps.shotwell/4352).

    However the Vala development team published libgee-0.8 in their PPA (https://launchpad.net/~vala-team/+archive/ppa)

    Would be anyway possible to install Shotwell on Precise using those libgee-0.8 precise libs?

    Thanks and regards.
    FR

Comments are closed.

Leave a Reply

Your email address will not be published. Required fields are marked *