Some compositor issues

So, now that the compositor is in trunk and everyone is excited, this might be a good time to mention some “issues”.

Firstly, it seems that there are some weird shadow redrawing problems…these just appeared recently, so it shouldn’t be hard to find the offending commit. I think I know what it is, I just need to work out why its not working.

Next: Now that some windows have argb visuals some buggy themes may have translucent parts where there weren’t translucent parts before. Gilouche was one of these themes and Jimmac fixed it up recently. So if you start seeing through the window title bars, tell your theme author.

Also, I’ve been getting reports of terrible performance and rendering issues with xgl. It seems xgl doesn’t like any of the non-GL compositors, so I don’t know what to do about that.

Finally, on a happier note – a big thank you to whoever bought me stuff from my wishlist. Its much appreciated, even if it did take me two days before I noticed my parents had piled up my mail in a weird place while I was away…

7 thoughts on “Some compositor issues”

  1. is it normal that the “alt-tab” popup takes some time (somethink like 1s/1.5s) to show up? (windows switching is fast as usual). Please note that I’m running gnome 2.20.1 with just metacity 2.21.5

    anyway your works rocks! Just a bit of shadows and some transparency is all we need :-D !

  2. It might, depending on your chipset…The alt-tab hasn’t been optimised yet, as I was waiting for the compositor to hit trunk so I could rewrite the whole thing :) There’s a lot that could be done to make it snappier.

  3. Running r3503 now, with composite on. Looks very nice and seems stable.

    If we could now only get ‘expose’ and that KDE4 thing where you can see all your desktops in miniture. That woudld be nice :)

Comments are closed.

Leave a Reply

Your email address will not be published. Required fields are marked *